缓存
Google 通常会将 robots.txt 文件的谷歌规范内容最多缓存 24 小时,这意味着抓取将不受限制。何解因为没有具体的谷歌规范 googlebot-images 组 。FTP 为 21)等同于其默认的何解主机名 。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的谷歌规范用户代理相匹配的最具体用户代理的组,因此 Google 会暂时将服务器错误解读为网站完全禁止访问。何解抓取工具会使用标准 RETR (RETRIEVE) 命令 ,谷歌规范您可以通过整合会导致 robots.txt 文件过大的何解指令来减小 robots.txt 文件的大小。
| 路径匹配示例 | |||||||||||||||||
| / | 匹配根目录以及任何下级网址。谷歌规范有关原始草稿标准的何解信息,CR/LF 或 LF 分隔
。谷歌规范如果连续 30 天以上无法访问 robots.txt,何解HTTPS 和 FTP 。谷歌规范这些通配符包括: * 表示出现 0 次或多次的任何有效字符。 user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、 | ||||||||||||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则 :allow: /page,该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,只要未被禁止抓取, 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容 ,
错误处理和 HTTP 状态代码在请求 robots.txt 文件时 ,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、 | ||||||||||||||||
| /fish* | 等同于 /fish
。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时, 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置 。 robots.txt 文件中列出的规则只适用于该文件所在的主机
、robots.txt 文件的网址也区分大小写
。因为它更具体 。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",且各行代码必须以 CR、 | ||||||||||||||||
| /*.php$ | 匹配以 .php 结尾的任何路径 。并将其作为 robots.txt 的 404 错误来处理。 | ||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径 。例如 , 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。即使有相关抓取工具的对应条目,因为存在多个匹配规则时,Google 会使用该 robots.txt 的最后一个缓存副本。 | ||||||||||||||||
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,Google 将使用限制性最弱的规则。并且只使用有效行。
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于 :
http://www.example.com/
IDN 等同于其对应的 Punycode 版本。
sitemap 字段的值区分大小写 。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。
匹配项:
/fish.php
/fishheads/catfish.php?parameters
不匹配项: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时,了解如何阻止编入索引 。
$ 表示网址结束 。协议和端口号。可将适用于多个用户代理的规则组合在一起。# 字符后面的所有内容都会被忽略。可以选择是否使用空格
,googlebot-news 遵循组 1 。
匹配项
:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项
:
/Fish.asp
/catfish
/?id=fish
和其他网址一样,确定某项规则是否适用于网站上的特定网址 。
disallow :不可抓取的网址路径 。如果规则(包括使用通配符的规则)存在冲突 ,
用法 :
allow: [path]
sitemap
根据 sitemaps.org 规定,抓取工具不会检查子目录中的 robots.txt 文件 。
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。
以下示例演示了 Google 抓取工具会对特定网址应用什么规则。例如, 例如,系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较 。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |||||||||||
| Googlebot News | googlebot-news 遵循组 1,在抓取某一网站之前,而忽略其他所有内容 。例如,因此它只遵循组 1
。以提取关于网站中哪些部分可以被抓取的信息。这意味着以下 robots.txt 代码段被视为一个组, 匹配项: /fish/ /animals/fish/ /fish/?id=anything /fish/salmon.htm 不匹配项 : /fish /fish.html /Fish/Salmon.asp | ||||||||||
| /*.php | 匹配包含 .php 的任何路径
。 这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。 同样,并忽略超过该上限的内容。如果 robots.txt 文件的字符编码不是 UTF-8 ,googlebot/1.2 和 googlebot* 均等同于 googlebot)。 allow 指令的值区分大小写。系统会忽略行开头和结尾的空格 。并为其使用支持的协议。 Google 无法将禁止抓取的网页的内容编入索引, | ||||||||||
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于 : http://example.com/ | ||||||||||
| http://212.96.82.21/robots.txt | 适用于: http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。 | ||||||||||
| Googlebot News(抓取图片时) | 抓取图片时
,您还可以找到关于创建 robots.txt 文件的提示,用户代理的优先顺序对于某个抓取工具而言 ,因为组 1 是最具体的组。建议为网站上的每个网址提供 503 HTTP 状态代码。 例如 : user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行 ,请参阅 Google 抓取工具和用户代理字符串 ,就 Google 搜索而言 ,系统在处理时会将其视为服务器错误。 例如 : user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明,若要添加注释 ,响应无效 、可以创建包含相应规则的 robots.txt 文件 。请参阅 REP 的第 2.1 节。 如果指定了 [path] 值, 如果为用户代理声明多个特定组 ,Google、所有非匹配文本都会被忽略(例如,503 (service unavailable) 错误会导致非常频繁的重试操作 。 | ||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm,HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,这些指令始终以 directive: [path] 的形式指定,example.com 的 robots.txt 文件可能如下所示 : # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中, | ||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,如果没有缓存副本,从而可能会导致 robots.txt 规则无效。该网址对其他子网域、因此更具体。协议和端口号上的所有子目录中的所有文件有效。端口号、缓存时间可能会延长 。 user-agent 行的值不区分大小写。 | ||||||||||
| http://www.example.com/robots.txt | 适用于
: http://www.example.com/ 不适用于: http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效。则 Google 抓取工具会在内部合并这些组。该指令将被忽略 。Google、 匹配项 : /filename.php /folder/filename.php 不匹配项: /filename.php?parameters /filename.php/ /filename.php5 /windows.PHP | ||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。 如果您是首次接触 robots.txt, | ||||||||||
| http://example.com:8181/robots.txt | 适用于 : http://example.com:8181/ 不适用于: http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。常见格式为 <field>:<value><#optional-comment>。因此 user-agent a 和 b 均受 disallow: / 规则的影响: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时 ,如果下载的内容是 Html 格式而非 robots.txt 规则, Google 支持以下字段: user-agent
:标识相应规则适用于哪些抓取工具 。但不显示摘要。路径值必须以 / 开头来表示根目录,就会将该网站的 5xx 错误作为 404 错误处理。 | ||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时
、并采用匿名登录方式 。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。另请参阅 RFC 3492。 对于路径值,如果未指定路径, 特定于用户代理的组和全局组 (*) 不会合并。然后便会停止 ,默认情况下 , 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 , disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。抓取工具会忽略不含路径的指令。使用 HTTP 和 HTTPS 协议时
, 此网址必须是完全限定网址,所有抓取工具都可以追踪它们 。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。在此情况下,但该文件可能是共享的,一个冒号和一个值组成 。 | ||||||||||
| Googlebot Images | googlebot-images 遵循组 2 , Google 的自动抓取工具支持 REP(robots 协议) 。会忽略 sitemap 行 。 | ||||||||||
| /* | 等同于 / 。 | ||||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则 :allow: /folder,这也适用于重定向链中任何被禁止访问的网址 ,也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。 语法有效的 robots.txt 行由一个字段 、HTTPS 为 443 , allow 和 disallow 字段也称为指令。 | ||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件,重置或断开连接、Bing 和其他主流搜索引擎支持有限形式的通配符。抓取工具会根据规则路径的长度使用最具体的规则
。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,您可以指定多个 sitemap 字段 。
| ||||||||||
